CCNP Switch Commands

Card Set Information

CCNP Switch Commands
2012-07-14 15:50:02
CCNP Commands Cisco Switch

CCNP Switch Commands
Show Answers:

  1. Find the location of a specific MAC address
    show mac address-table dynamic address mac-address
  2. Display all MAC addresses learned on a specific interface
    show mac address-table dynamic interace type number
  3. Display the current CAM table size
    show mac adress-table count
  4. Enter a static CAM table entry
    mac address-table static mac-address vlan vlay-id interface type number
  5. Clear a CAM entry
    clear mac address-table dynamic [address mac-address | interface type number | vlan vlan-id]
  6. Select a Port
    interface type module/number
  7. Select multiple ports
    interface range type module/number [type module/number...]


    interface range tpe module/first-number - last-number
  8. Define an interface macro
    define interface-range macro-name type module/number


    Interface range macro macro-name 
  9. Identify port
    description description-string
  10. set port speed
    speed {10 | 100 | 1000 | Auto}
  11. Set port mode
    duplex {auto | full | half}
  12. Detect port error conditions
    errdisable detect cause [all | cause-name]
  13. Automatically recover from errdisable
    • errdisable recovery cause [all | cause-name]
    • errdisable recovery interval seconds
  14. Manually recover from errdisable
    • shutdown
    • no shutdown
  15. Create a VLAN
    vlan vlan-num

    • name vlan-name
  16. Assign port to VLAN
    interface type module/number

    switchport mode access

    switchport access vlan
  17. Configure a trunk
    interface tpe mod/port

    switchport trunk encapsulation {isl | dot1q | negotiate}

    • switchport trunk native vlan vlan-id

    switchport trunk allowed vlan 
    {vlan-listall | {add except remove} vlan-list}

    switchport mode {trunk dynamic {desirable  auto}}
  18. Verify VLAN configuration
    show vlan id vlan-id
  19. Verify active trunk parameters
    shwo interace type mod/num trunk
  20. Compare trunk configuration and active parameters
    show interface type mod/um switchport
  21. Verify DTP operation
    show dtp [interface type mod/num]
  22. Display current VTP parameters, including the last advertising server
    show vtp status
  23. Displays VTP advertisement and pruning statistics
    show vtp counters
  24. Displays defined VLANs
    show vlan brief
  25. Displays trunkstatus, including pruning eligibility
    show interface type mod/num pruning
  26. Define the VTP domain
    vtp domain domain-name
  27. Set the VTP mode
    vtp mode {server | client | transparent}
  28. Define an optional VTP password
    vtp password password
  29. Configure VTP version
    vtp version {1 | 2}
  30. Enable VTP pruning
    vtp pruning
  31. Select VLANs elible for pruning on a trunk interface
    interface type mod/num switchport trunk pruning vlan {add | except | none |remove} vlan-list
  32. show current EtherChannel status of each member port
    show etherchannel summary

    show eitherchannel port
  33. tiem stamps of EtherChannel changes
    show etherchannel port-changes
  34. detailed status about each EtherChannel component
    show etherchannel detail
  35. Load-balancing hashing algorithm
    show etherchannel load-balance
  36. Load-balancing port index used by hashing algorithm
    show etherchannel port-channel
  37. EtherChannel neighbors on each port
    show {pagp | lacp} neighbor
  38. LACP system ID
    show lacp sys-id
  39. Select a load-balancing method for the switch
    port-channel load-balance method
  40. Use a PAgP mode on an interface
    channel-protocol pagp

    number mode {on | {{auto | desirable} [non-silent]}}
  41. Assign the LACP system priority
    lacp system priority priority
  42. Use an LACP mode on an interface
    channel-protocol lacp

     number mode {on | passive | active}

    • lacp port-priority priority
  43. Enable an entire instance of STP
    Global config command:

    switch(config)# spanning-tree vlan vlan-id
  44. Enable STP that has been disabled on a specific VLAN [on a specific port]
    interface configuration command:

    switch(config-if)# spanning-tree vlan vlan-id
  45. View all possible STP parameters for all VLANs (port info is summarized)
    switch# show spanning-tree
  46. View all possible STP information for all VLANs (port info is very detailed)
    switch# show spanning-tree detail
  47. View the total number of switch ports currently in each of the STP states
    switch# show spanning-tree [vlan vlan-id] summary
  48. Find the root bridge ID, the root port and the root path cost
    switch# show spanning-tree [vlan vlan-idroot
  49. Show the bridge ID and STP timers for the local switch
    switch# show spanning-tree [vlan vlan-id] bridge
  50. Show the STP activity on a specific interface
    switch# show spanning-tree interface type port
  51. Show the STP UplinkFast status
    switch# show spanning-tree uplinkfast
  52. Show the STP BackboneFast status
    switch# show spanning-tree backbonefast
  53. Enable STP
    switch(config)# spanning-tree vlan-id
  54. Set bridge priority
    switch(config)# spanning-tree vlan vlan-id priority bridge-priority
  55. Set root bridge (macro)
    switch(config)# spanning-tree vlan vlan-id root {primary | secondary} [diameter diameter]
  56. Set port cost (interface command)
    switch(config-if)# spanning-tree [vlan vlan-id] cost cost
  57. Set port priority (interface command)
    switch(config-if)# spanning-tree [vlan vlan-id] port-priority port-priority
  58. Set STP timers
    switch(config)# spanning-tree [vlan vlan-id] hello-time seconds

    switch(config)# spanning-tree [vlan vlan-id] forward-time seconds

    • switch(config)# spanning-tree [vlan vlan-id] max-age seconds
  59. Set PortFast on an interface
    switch(config-if)# spanning-tree portfast
  60. Set UplinkFast on a switch
    switch(config)# spanning-tree uplinkfast [max-update-rate pkts-per-second]
  61. Set BackboneFast on a switch
    switch(config)# spanning-tree backbonefast
  62. Enable Root Guard on  per-port basis
    switch(config-if)# spanning-tree guard root
  63. List the ports that have been labeled in an inconsistent state
    switch# show spanning-tree inconsistentports
  64. Look for detailed reasons for inconsistencies
    switch# show spanning-tree interface type mod/num [detail]
  65. Display the global BPDU Guard, BPDU filter, and Loop Guard States
    switch# show spanning-tree summary
  66. Display the UDLD status on one or all ports
    switch# show udld [type mod/num]
  67. Reenable ports that UDLD aggressive mode has errdisabled
    switch# udld reset
  68. Enable BPDU Guard
    switch(config)# spanning-tree portfast bpduguard default


    switch(config-if)# spanning-tree bpduguard enable
  69. Enable Loop Guard
    switch(config)# spanning-tree loopguard default


    switch(config-if)# spanning-tree guard loop
  70. Enable UDLD
    switch(config)# udld {enable | aggressive | message time seconds}


    switch(config-if)# udld {enable | aggressive | disable}
  71. Enable BPDU filtering
    switch(config)# spanning-tree bpdufilter default


    switch(config-if)# spanning-tree bpdufilter enable
  72. Configure a port as an RSTP edge port
    switch(config-if)# spanning-tree portfast
  73. Force a port to act as a point-to-point link
    switch(config-if)# spanning-tree link-type point-to-point
  74. configure rapid STP
    switch(config)# spanning-tree mode rapid-pvst

  75. Set root bridge (macro)
    switch(config)# spanning-tree mst instance-id root {primary | secondary | diameter diameter}
  76. Set bridge priority
    swtich(config)# spanning-tree mst instance-id priority bridge-priority
  77. set port cost
    switch(config)# spanning-tree mst instance-id cost cost
  78. set port priority
    switch(config)# spanning-tree mst instance-id port-priority port-priority
  79. Enable MST on a switch
    switch(config)# spanning-ree mode mst
  80. Enter MST configuration mode
    switch(config)# spanning-tree mst configuration
  81. Name the MST region
    switch(config-mst)# name name
  82. Set the configuration revision number
    switch(config-mst)# revision version
  83. Display a ports L2 or L3 current status
    switch# show interface type mod/num switchport
  84. Display FIB table entries related to speciic inerface or VLAN
    switch# show ip cef [type mod/num | vlan vlan-id] [detail]
  85. Display the adjacency table contents
    switch# show adjacency [type mod/num | vlan vlan-idI] [summary | detail]