CCNA:ICND2 ?'s - sec 3

Card Set Information

Author:
shamgar_bn
ID:
264359
Filename:
CCNA:ICND2 ?'s - sec 3
Updated:
2014-05-20 21:09:43
Tags:
Cisco CCNA ICND2
Folders:

Description:
Open ended questions for section 3 of Cisco's CCNA ICND2
Show Answers:

Home > Flashcards > Print Preview

The flashcards below were created by user shamgar_bn on FreezingBlue Flashcards. What would you like to do?


  1. Create a minimal configuration enabling IP on each interface on a 2600 series router (two serial, one Ethernet). The Network Information Center (NIC) assigns you network 192.168.1.0. Your boss says that you need, at most, 60 hosts per LAN subnet. You also have point-to-point links attached to the serial interfaces. When choosing the IP address values and subnet numbers, you decide to start with the lowest numerical values. Assume that point-to-point serial links will be attached to this router and that EIGRP is the routing protocol. (Avoid using the zero subnet.)
    • interface ethernet 0/0
    • ip address 192.168.1.65 255.255.255.192
    • interface serial 0/0
    • ip address 192.168.1.129 255.255.255.252
    • interface serial 0/1
    • ip address 192.168.1.133 255.255.255.252
    • router eigrp 1
    • network 192.168.1.0
  2. Write down the steps you would take to migrate from RIP to OSPF in a router whose current RIP configuration includes only router rip followed by a network 10.0.0.0 command. Assume a single OSPF area, and use as few network commands as possible.
    • router ospf 5
    • network 10.0.0.0 0.255.255.255 area 0
    • no router rip
  3. Create a configuration for EIGRP on a router with these interfaces and addresses: e0 using 10.1.1.1, e1 using 224.1.2.3, s0 using 10.1.2.1, and s1 using 199.1.1.1. Use AS 5.
    • router eigrp 5
    • network 10.0.0.0
    • network 199.1.1.0
    • If you noticed that 224.1.2.3 is not a valid Class A, B, or C address, you get full credit. A new address is needed for Ethernet1, with a matching "network" command.
  4. Create a configuration for EIGRP on a router with these interfaces and addresses: e0 using 200.1.1.1, e1 using 128.1.3.2, s0 using 192.0.1.1, and s1 using 223.254.254.1.
    • router eigrp 1
    • network 200.1.1.0
    • network 128.1.0.0
    • network 192.0.1.0
    • network 223.254.254.0
    • Because four different networks are used, four "network" commands are required. If you noticed that this question does not specify the AS number (1 in this example) but configured one, you get full credit.
  5. From a router’s user mode, without using debugs or privileged mode, how can you determine what routers are sending you EIGRP routing updates?
    The "show ip protocol" command output lists the routing sources--the IP addresses of routers sending updates to this router. Also, the "show ip route" command lists next-hop router IP addresses. The next-hop routers listed identify the routers that are sending routing updates. The "show ip eigrp neighbor" and "show ip eigrp interface" commands also list neighbors that by definition send routing updates.
  6. If the command router eigrp 1, followed by network 10.0.0.0, with no other network commands, is configured in a router that has an Ethernet0 interface with IP address 168.10.1.1, does EIGRP send updates out Ethernet0?
    No. There must be a network statement for 168.10.0.0 before EIGRP advertises out that interface. The "network" command simply selects the connected interfaces on which to send and receive updates.
  7. If the command router ospf 1, followed by network 10.0.0.0 0.255.255.255 area 0, with no other network commands, is configured in a router that has an Ethernet0 interface with IP address 10.10.1.1, does OSPF send updates out Ethernet0?
    Not necessarily. OSPF must discover other OSPF neighbors on the interface before it advertises routing information (LSAs)
  8. If the commands router eigrp 1 and network 10.0.0.0 are configured in a router that has an Ethernet0 interface with IP address 168.10.1.1, mask 255.255.255.0, does this router have a route to 168.10.1.0?
    Yes. The route is in the routing table because it is a directly connected subnet, not because of any action by EIGRP
  9. Which command lists all IP routes learned via OSPF, and only those routes?
    sh ip route ospf
  10. Compare and contrast the type of information exchanged in routing updates sent by distance vector routing protocols versus link-state protocols.
    Distance vector protocols advertise subnets and their associated metric values. Link-state protocols advertise information about routers and subnets, or links, in the network, along with metric information for the links. Link-state protocols describe the full topology in the network. As a result, link-state routing information is much more detailed than distance vector protocols.
  11. Define balanced hybrid, and give an example of a balanced hybrid protocol.
    Cisco uses the term balanced hybrid to describe a class of routing protocols that have some distance vector characteristics and some link-state characteristics. Currently, only EIGRP falls into this category.
  12. Describe how balanced hybrid protocols differ from distance vector protocols in terms of how a router notices that a neighboring router has failed.
    Distance vector routing protocols rely on regular full routing updates from each neighboring router. If a router fails to receive those updates for a period of time, the router that fails to receive the updates assumes that the other router has failed. Balanced hybrid protocols do not send full updates regularly; instead, the send periodic Hello messages. If Hello messages are not received for some timeout period, the router that is no longer receiving the updates assumes that the other router has failed.
  13. List the distance vector loop-avoidance features used by OSPF, such as split horizon.
    OSPF, as a link-state routing protocol, does not need to use any of the distance vector loop-avoidance features. Loop avoidance is effectively built into the routing protocol.
  14. List two OSPF features that help decrease the size of the OSPF topology database.
    If you use multiple OSPF areas, the size of the database in routers that are not ABRs decreases. Also, by using some stub area type, you can reduce the size of the topology database even further.
  15. Assume that you must choose between OSPF and EIGRP for a routing protocol in a new network you are building. List and explain the most compelling reason to choose OSPF and the most compelling reason to choose EIGRP.
    OSPF converges fast, like EIGRP, but it is an open standard, unlike EIGRP. Therefore, OSPF would more easily allow routers from multiple vendors to be used. EIGRP converges quickly, like OSPF, but requires little or no engineering design, whereas OSPF requires significant engineering design effort in larger networks.
  16. Name the two commands typically used to create a default route for a router.
    • ip default-network
    • ip route 0.0.0.0 0.0.0.0
  17. Assume that subnets of network 10.0.0.0 are in the IP routing table in a router but that no other network and subnets are known, except that there is also a default route (0.0.0.0) in the routing table. A packet destined for 192.1.1.1 arrives at the router. What configuration command determines whether the default route is used in this case?
    The packet is routed using the default route, regardless of other configuration commands. In this scenario, in which the Class A, B, or C network is known, there is no match for the destination in the known subnets, and as a default exists, so the default must be used.
  18. Assume that subnets of network 10.0.0.0 are in the IP routing table in a router but that no other network and its subnets are known, except that there is also a default route (0.0.0.0) in the routing table. A packet destined for 10.1.1.1 arrives at the router, but no known subnet of network 10 matches this destination address. What configuration command determines whether the default route is used in this case?
    If the command "ip classless" is configured, the packet is routed using the default route. If "no ip classless" is configured, the packet is discarded.
  19. What feature supported by EIGRP allows it to support manual VLSM?
    The association and transmission of mask information with each route allows VLSM support with any routing protocol.
  20. List the interior IP routing protocols that have autosummarization enabled by default. Which of these protocols allow autosummarization to be disabled using a configuration command?
    • RIP-1
    • RIP-2
    • IGRP
    • EIGRP
  21. Which interior IP routing protocols support manual route summarization?
    • EIGRP
    • OSPF
    • IS-IS
    • RIP-2
  22. Assume that several subnets of network 172.16.0.0 exist in a router’s routing table. What must be true about these routes for the output of the show ip route command to list mask information only on the line that lists network 172.16.0.0 but that doesn’t show mask information on each route for each subnet?
    If all the subnets of 172.16.0.0 use the same mask, the output of the "show ip route" command lists only the mask in the heading line for the network. If VLSM were in use, each route for each subnet would reflect the mask used in that case.
  23. Router A and Router B are connected via a point-to-point serial link. Router A’s interfaces use IP address 172.16.1.1, mask 255.255.255.0 and address 172.16.2.1, mask 255.255.255.0. Router B’s interfaces use address 172.16.2.2, mask 255.255.255.0 and address 10.1.1.1, mask 255.255.254.0. Is VLSM in use? Explain your answer.
    Although two different masks are used, VLSM is not used. VLSM implies that two different masks are in use in the same Class A, B, or C network. In this example, only one mask is used for each classful network
  24. What is the smallest summarized route that summarizes the subnets 10.1.63.0, 10.1.64.0, 10.1.70.0, and 10.1.71.0, all with mask 255.255.255.0?
    Only the first 17 bits of these subnet numbers are in common. Therefore, the smallest summary is 10.1.0.0, mask 255.255.128.0
  25. What is the smallest summarized route that summarizes the subnets 10.5.111.0, 10.5.112.0, 10.5.113.0, and 10.5.114.0, all with mask 255.255.255.0?
    The first 19 bits of these subnet numbers are in common. Therefore, the smallest summary is 10.5.96.0, mask 255.255.224.0
  26. What is the smallest summarized route that summarizes the subnets 10.5.110.32, 10.5.110.48, and 10.5.110.64, all with mask 255.255.255.248?
    The first 21 bits of these subnet numbers are in common. Therefore, the smallest summary is 10.5.108.0, mask 255.255.248.0
  27. Of the routing protocols RIP-1, IGRP, EIGRP, and OSPF, which are classless?
    • EIGRP
    • OSPF
  28. Of the routing protocols RIP-1, IGRP, EIGRP, and OSPF, which support VLSM?
    • EIGRP
    • OSPF
  29. Of the routing protocols RIP-1, IGRP, EIGRP, and OSPF, which advertise mask information along with subnet numbers?
    • EIGRP
    • OSPF
  30. Of the terms classful routing, classful routing protocol, classless routing, and classless routing protocol, which describe a feature that affects when a router uses the default route?
    Classful routing and classless routing define rules by which a router chooses whether to use the default route
  31. What allows for the successful use of a discontiguous Class A, B, or C IP network—classful routing, classful routing protocol, classless routing, or classless routing protocol?
    Whether a routing protocol is or is not classless defines whether it can support discontiguous networks. Only a classless routing protocol supports discontiguous networks.
  32. Compare and contrast route summarization and autosummarization.
    Route summarization allows an engineer to choose a summary route to configure, advertising the summary as opposed to the more specific routes. Autosummarization summarizes only a Class A, B, or C network number, and only at the boundary between the network and another network.
  33. Of the routing protocols RIP-1, IGRP, EIGRP, and OSPF, which use autosummarization by default and also cannot have autosummarization disabled?
    RIP-1 and IGRP
  34. What command switches a router from classless routing to classful routing?
    "no ip classless" disable classless routing, thereby enabling classful routing.
  35. Define private addressing as defined in RFC 1918.
    Some hosts will never need to communicate with other hosts across the Internet. For such hosts, assigning IP addresses from registered networks wastes IP addresses. To conserve IP addresses, a set of network numbers, called private addresses, has been reserved and can be used in these cases to help conserve IP addresses for use over the Internet.
  36. List the range of private networks defined in RFC 1918.
    • Class A network - 10.0.0.0
    • Class B network - 172.16.0 to 172.31.0.0
    • Class C network - 192.168.0.0 to 192.168.255.0
  37. Does CIDR affect the size of Internet routing tables? If so, what does it do to those routing tables?
    CIDR allows ISPs to summarize multiple Class A, B, or C networks, typically Class C networks, into summary routes. It shortens the length of the IP routing table, improving Internet routing performance.
  38. Define NAT and explain the basics of its operation.
    Network Address Translation is a mechanism for allowing hosts with private addresses or addresses that conflict with IP addresses from a registered network to communicate with hosts over the Internet. The basic operation involves the NAT router changing the IP addresses in packets to and from these hosts so that only legitimately registered IP addresses are used in flows through the Internet.
  39. Describe the process used by IP routers to perform fragmentation and reassembly of packets.
    When a packet must be forwarded, but the packet is larger than the maximum transmission unit (MTU) size for the outgoing interface, the router fragments the packet as long as the Don't Fragment bit is not set in the packet header. No IP router reassembles the fragments; fragments are reassembled at the final destination host.
  40. How many Class B-style networks are reserved by RFC 1918 private addressing?
    • Sixteen.
    • 172.16.0.0 through 172.31.0.0
  41. Describe why ARP requests use an Ethernet broadcast address instead of an Ethernet unicast address.
    Hosts use ARP when they need to learn the MAC address of another IP host. Because the host does not know the MAC address, it would be impossible to use an Ethernet unicast, because the host would not know the right MAC address to put in the destination address field in the Ethernet frame.
  42. Imagine that R1 has an interface, FastEthernet 0/0, that uses ISL trunking to a switch. R1 needs to route between VLAN 1 and VLAN 2. Create a valid router configuration.
    • interface fastethernet 0/0.1
    • ip address 10.1.1.1 255.255.255.0
    • encapsulation isl 1
    • !
    • interface fastethernet 0/0.2
    • ip address 10.1.2.1 255.255.255.0
    • encapsulation isl 2
  43. Describe how NAT overload manages to support more than one inside local IP address using a single inside global address.
    NAT overload uses Port Address Translation (PAT) to essentially translate both the source address and port numbers for incoming inside packets. By allocating unique port numbers to be used with a single inside global IP address, NAT overload can make multiple sockets on multiple inside hosts appear to be multiple sockets, but from a single host, on the public part of the network.

What would you like to do?

Home > Flashcards > Print Preview