CCNA Commands

Card Set Information

Author:
Anonymous
ID:
81352
Filename:
CCNA Commands
Updated:
2011-04-24 02:15:52
Tags:
CCNA Cisco CLI Commands
Folders:

Description:
CLI Commands for Cisco Routers
Show Answers:

Home > Flashcards > Print Preview

The flashcards below were created by user Anonymous on FreezingBlue Flashcards. What would you like to do?


  1. The steps to configure a router as a DHCP server are as follows:
    Step 1. Define a range of addresses that DHCP is not to allocate. These are usually static addresses reserved for the router interface, switch management IP address, servers, and local network printers.

    Step 2. Create the DHCP pool using the ip dhcp pool command.

    Step 3. Configure the specifics of the pool.
  2. Configuring DHCP Step 1: Excluding IP Addresses
    R1(config)#ip dhcp excluded-address low address [high address]
  3. Configuring DHCP Step 2: Configuring a DHCP Pool
    R1(config)#ip dhcp pool pool-name
  4. Configuring DHCP Step 3: Specific Tasks

    (Required Tasks)
    • Define the address:
    • R1(dhcp-config)#pool network network-number [mask | /prefix-length]

    • Define the default router or gateway:
    • R1(dhcp-config)#default-router address [address2...address8]
  5. PPP Configuration steps:
    R3(config)#interface serial 0/0/0

    R3(config-if)#encapsulation ppp

    R3(config-if)#ppp authentication chap

    • R3(config)#username USER password
    • PASS

    Router(config-if)#ppp chap hostname USER

    Router(config-if)#ppp chap password PASS
  6. Static NAT Step 1
    Establish static translation between an inside local address and an inside global address:

    Router(config)#ip nat inside source static local-ip global-ip
  7. Static NAT Step 2
    Specify the inside interface:

    Router(config)#interface type number
  8. Static NAT Step 3
    Mark the interface as connected to the inside:

    Router(config-if)#ip nat inside
  9. Static NAT Step 4
    Exit interface configuration mode:

    Router(config-if)# exit
  10. Static NAT Step 5
    Specify the outside interface:

    Router(config)#interface type number
  11. Static NAT Step 6
    Mark the interface as connected to the outside:

    Router(config-if)#ip nat outside
  12. Configuring Dynamic NAT 1
    • Define a pool of global addresses to be allocated as needed
    • Router(config)#ip nat pool name start-ip end-ip {netmask netmask|prefix-length prefix-length}
  13. Configuring Dynamic NAT 2
    Define a standard access list permitting those addresses that are to be translated:

    Router(config)#access-list access-list-number permit source [source-wildcard]
  14. Configuring Dynamic NAT 3
    Establish dynamic source translation, specifying the access list defined in the prior step.

    Router(config)#ip nat inside source list access-list-number pool name
  15. Configuring Dynamic NAT 4
    Specify the inside interface.

    Router(config)#interface type number
  16. Configuring Dynamic NAT 5
    Mark the interface as connected to the inside.

    Router(config-if)#ip nat inside
  17. Configuring Dynamic NAT 6
    Specify the outside interface.

    Router(config)#interface type number
  18. Configuring Dynamic NAT 7
    Mark the interface as connected to the outside.

    Router(config-if)#ip nat outside
  19. NAT Overload Configuration 1
    Define a standard access list permitting those addresses that are to be translated.

    Router(config)#access-list acl-number permit source [source-wildcard]
  20. NAT Overload Configuration 2
    Establish dynamic source translation, specifying the access list defined in the prior step.

    Router(config)#ip nat inside source list acl-number interface interface overload
  21. NAT Overload Configuration 3
    Specify the inside interface.

    • Router(config)#interface type number
    • Router(config-if)#ip nat inside
  22. NAT Overload Configuration 4
    • Specify the outside interface.
    • Router(config-if)#interface type number
    • Router(config-if)#ip nat outside
  23. NAT Overload Configuration for Pool of addresses 1
    Define a standard access list permitting those addresses that are to be translated.

    Router(config)#access-list acl-number permit source [source-wildcard]
  24. NAT Overload Configuration for Pool of addresses 2
    Specify the global address, as a pool, to be used for overloading.

    Router(config)#ip nat pool name start-ip end-ip {netmask netmask | prefix-length prefix-length}.
  25. NAT Overload Configuration for Pool of addresses 3
    Establish overload translation.

    Router {config}#ip nat inside source list acl-number pool name overload
  26. NAT Overload Configuration for Pool of addresses 4
    Specify the inside interface.

    • Router(config-if)#interface type number
    • Router(config-if)#ip nat inside
  27. NAT Overload Configuration for Pool of addresses 5
    Specify the outside interface.

    • Router(config-if)#interface type number
    • Router(config-if)#ip nat outside
  28. Standard access-list configuration
    Router(config)#access-list access-list-number [deny | permit | remark] source [source-wildcard]

    Router(config)# int type number

    Router(config-if)#ip access-group {access-list-number | access-list-name} {in | out}
  29. Using an ACL to Control VTY Access
    Router(config)#access-list access-list-number [deny | permit | remark] source [source-wildcard]

    Router(config)#line vty 0 4

    • Router(config-line)#login
    • Router(config-line)#password password
    • Router(config-line)#access-class access-list-number {in [vrf-also] | out}

What would you like to do?

Home > Flashcards > Print Preview